Back to overview
Resolved

Case list is blank for some users who have logged in recently

Jul 13, 2026 at 6:52pm UTC
Affected services
app.juryboxapp.com

Resolved
Jul 13, 2026 at 7:13pm UTC

A fix has been pushed and verified in production

Created
Jul 13, 2026 at 6:52pm UTC

After logging in, users are presented with a blank case list. Our team has identified the issue and is working on a fix.