Back to overview
Resolved

API server experiencing long delays

Aug 4, 2026 at 9:30pm UTC
Affected services
app.juryboxapp.com
api.juryboxapp.com

Resolved
Aug 4, 2026 at 9:36pm UTC

We have successfully deployed a fix to the API server and have seen all the queued changes drain and sync. If you were experiencing issues, please reload the web app or close and open the iPad app.

Created
Aug 4, 2026 at 9:30pm UTC

An issue with the collaborative layer is impeding the relay of information between clients. A fix has been identified and is currently being prepared for deployment